Cara blok semua situs kecuali situs tertentu di mikrotik

Berawal dari permintaan client untuk memblokir semu situs dan hanya situs tertentu yang di bolehkan, yang dibolehan hanya , bpjs, pajak, gmail,yahoo,dan beberapa situs tertentu yang di rekomendasikan. Akhirnya mulailah saya browsing dan googling. Setelah beberapa langkah dicoba sepertinya langkah berikut ini yang cukup efektif.

Simak langkah-langkahnya Cara blok semua situs kecuali situs tertentu di mikrotik berikut.
Pertama yang harus dlikakukan adalah membuat rule pada  IP > Firewall > Layer 7 Protocols. Buat baru dengan klik tanda + nama block-website (Atau Terserah anda) dan Regexp nya :

1. ip>firewall>layer7 protocol
Regexp:

^.*$

Nb: script {^.*$} bertujuan untuk memblokir semua situs

2. masih di layer7protocol tambahkan 1 lagi untuk situs yang di izinkan klik  tanda + lagi nama open-website (atau terserah anda) dan regexp nya :

^.+(bpjs|pajak|google|gmail|yahoo|dan situs lainnya).*$

Nb: daftar diatas adalah situs yang di bolehkan untuk dibuka

Jika sudah klik ok

sekarang kita masuk ke filter rulenya untuk yang di perbolehkan di akses

ip>firewall filter>

atau dengan script berikut

/ip firewall filter add chain=forward src-address=192.168.1.7 protocol=tcp  layer7-protocol=bleh-website action=accept

Nb: ip address 192.168.1.7 sesuaikan dengan ip local komputer atau bisa keseluruhan dengan membuat ip 192.168.1.0/24.

Lalu tambahkan 1 lagi untuk yang kita blok semua website

/ip firewall filter add chain=forward src-address=192.168.1.7 protocol=tcp  layer7-protocol=blok-website action=drop

Untuk yang kedua hampir sama dengan yang pertama cuma bedanya di layer7 protocol dan actionnya kalau yang pertama accept yang kedua kita drop

Hasilnya seperti ini

Sudah selesai tnggal di coba untuk hasilnya.

Semoga bermanfaat.